Need help doing multi tile normal map workflow in softimage

Discussions regarding Materials, Material-Compounds or Shaders, etc.
sampad01
Posts: 5
Joined: 19 May 2013, 17:01
Skype: sampad01

Need help doing multi tile normal map workflow in softimage

Post by sampad01 » 05 Sep 2013, 17:58

Hello, folks. Its my first post here.
I spent about 24 hours straight reading forums and tinkering in softimage xsi's render tree but I failed to plug multi tile normal maps to one material.
Here is the situation.
I got a character made in zbrush. It has 3 uv tiles. I can use mix 8 colors node to use the 3 color textures for the material. It works fine.
But not for normal maps. Because, xsinormalmap 3 node has built in U and V transformations. So, I can only show 1 UV tile using one xsinormalmap 3 node.
I tried converting 3 normal map nodes from vector to color and adding them up into mix 8 layers node and then converting the color back to vector and plugged that to the material's bump input.
It looked horrible.
I tried daisy chaining vector-vector nodes and used vector input 1 + vectore input 2 and all other types. It wokrs but each time I add a new normal map. the overall output gets washed out by 10-20% and the result looks very blurred or washed out.

I am sure I am not doing this right. I am new to xsi. Please help me setup multi tile normal maps for single material in render tree. Thanks in advance. :-??

Sampad
cgdesk.net

User avatar
AceMastermind
Posts: 158
Joined: 15 Jun 2009, 00:57

Re: Need help doing multi tile normal map workflow in softimage

Post by AceMastermind » 06 Sep 2013, 05:46

Please define "uv tiles", are you saying you have one object with three UV sets? Is it imperative that you connect them all to the same material? You said you're new to Softimage, are you familiar with how clusters work? I'm not an expert, i'm just trying to understand your situation and offer whatever advice I can until someone more experienced comes along.

sampad01
Posts: 5
Joined: 19 May 2013, 17:01
Skype: sampad01

Re: Need help doing multi tile normal map workflow in softimage

Post by sampad01 » 06 Sep 2013, 08:45

AceMastermind wrote:Please define "uv tiles", are you saying you have one object with three UV sets? Is it imperative that you connect them all to the same material? You said you're new to Softimage, are you familiar with how clusters work? I'm not an expert, i'm just trying to understand your situation and offer whatever advice I can until someone more experienced comes along.
Please have a look at these screenshots.

Image
Image
Image

The pictures say it all. What I did was, made 3 tiles of UV. Like the first screenshot. Then I made 3 normal maps from zbrush using multimap exporter.
Now, I can apply a normal map for each tile using the advanced tab of xsinormalmap node. I set up the uv coordinates there and they work nicely. As you can see, I can have each normal map applied separately and they looks good. But when I combine them in the mix 8 layers node, using "Add" function, or any other function. they look washed out as each new normal map is added.
Please tell me the right way to do it.
Thanks.


Sampad
http://cgdesk.net
You do not have the required permissions to view the files attached to this post.

j3st3r
Posts: 121
Joined: 11 Jun 2009, 09:13

Re: Need help doing multi tile normal map workflow in softimage

Post by j3st3r » 06 Sep 2013, 12:25

II'd suggest to use the Vector-Vector node. Set it to Minimum or Maximum and connect to XSINormalMap node, then daisy chain them, so always two nodes are getting in.

See attached screenshot.

Let me know if it helped
You do not have the required permissions to view the files attached to this post.

sampad01
Posts: 5
Joined: 19 May 2013, 17:01
Skype: sampad01

Re: Need help doing multi tile normal map workflow in softimage

Post by sampad01 » 06 Sep 2013, 14:19

j3st3r wrote:II'd suggest to use the Vector-Vector node. Set it to Minimum or Maximum and connect to XSINormalMap node, then daisy chain them, so always two nodes are getting in.

See attached screenshot.

Let me know if it helped

Thank you so much! I tried your method but have a look at these new screenshots. I think the result is not exactly the same. Though its very close but you can see how much highlight is lost and sharpness is also lost. Any idea?

Image

Uploaded with ImageShack.us

Image

Uploaded with ImageShack.us

Image

Uploaded with ImageShack.us

slowdive
Posts: 35
Joined: 07 Sep 2011, 22:52

Re: Need help doing multi tile normal map workflow in softimage

Post by slowdive » 06 Sep 2013, 18:20

wish i knew that a week ago ~x(